Projeto Integrador - 2014.1 - Remanescentes

De MediaWiki do Campus São José
Ir para: navegação, pesquisa
Remanescentes.jpg


10/06/2014 Início do Projeto

  • Nome foi escolhido por nossa equipe pelo motivo, de apenas termos colegas que estudam juntos desde o início do semestre 2013.1.
  • Foi realizado a passagem da fibra óptica do Laboratório de Redes até o Laboratório de Meios, utilizando dutos e calhas já disponíveis.
  • As configurações das máquinas, não foram realizadas. Equipamentos não davam boot via pendrive.
  • Lista da configuração será atualizada no dia 13/06/2014.
  • Na parte final da aula, não houve trabalho referente ao projeto, motivo: Prova de Recuperação com o Professor Saul.
  • Passagem do Link de Fibra, acompanhada pelo Professor Saul.

11/06/2014

  • Instalação do Sistema operacional, utilizando DVD fornecido pelos próprios alunos.
  • Sistema operacional instalado: Ubuntu Server 12.04.4, foi escolhida esta versão pelo motivo de baixo requerimento, conforme equipamentos.
  • Atualização do Ubuntu Server, utilizando os comandos:
 sudo apt-get update
sudo apt-get upgrade 
sudo apt-get dist-upgrade.
  • Instalação de serviços, utilizando o comando:
 sudo apt-get install open-dns
sudo apt-get install SSH
sudo apt-get install idap
sudo apt-get install bind9
sudo apt-get install apache2
sudo apt-get install isc-dhcp-server

Servidor20.jpg

  • Configurados senhas de acesso e root.
  • Alteração da posição do Modem de Backup, do slot 2 para o slot 10.
  • Instalação conversor de mídia, apenas a parte do par metálico. (TP-link MC200CM)
  • Fornecido os equipamentos para instalação do Hotspot. (Edimax EW-7209APg)
  • Link de backup par metálico entre o Laboratório de Meios e Redes I, instalado e testado.
  • Nos Rack's, estão faltando tomadas de energia elétrica.
  • Cabeamento ainda não foi identificado, por falta do etiquetador padrão de Cabeamento Estruturado.
  • Professor Jorge Casagrande, acompanhou instalação e testes.

Testeset.jpg

Linktestado.jpg

12/06/2014

  • Por motivo de Abertura da Copa e jogo da Seleção Brasileira, não haverá aula. Sendo retomada atividades no dia 13/06/2014.
  • Integrantes da equipe irão pesquisar sobre os assuntos e trocar emails.

13/06/2014

  • Informações técnica do servidor:

- Processador: Intel Pentium(R) Dual CPU E2140 @ 1.60GHz x 2

- Memória RAM 2GB.

- Disco: 311,7 GB

- OS type: 32-bits


  • Sistema Operacional:

Ubuntu-Server 12.04 LTS

  • Instalação do modo gráfico.


  • Instalação de serviços, utilizando o comando:
 
Sudo ifconfig eth0 192.168.1.123/24
ping 8.8.8.8

sudo apt-get install samba
sudo apt-get install nfs-kernel-server
sudo apt-get install gnome
sudo apt-get install firefox
sudo apt-get install freeradius freeradius-mysql
sudo apt-get install squid


  • Configuração do DNS:
;
; BIND data file for local loopback interface
;
$TTL   604800
@        IN       S0A        remanescentes.sj.ifsc.edu.br. root.remanescentes.sj.ifsc.edu.br. (
                                 2               ; Serial
                            604800               ; Refresh      
                             86400               ; Retry
                           2419200               ; Expire
                            604800 )             ; Negative Cache TTL

;
@        IN        A       172.16.16.253
@        IN        NS      ns1.nat.sj.ifsc.edu.br
@        IN        A       127.0.0.1
@        IN        AAAA    ::1
ns       IN        A       172.16.16.253
www      IN        CNAME   remanescentes.sj.ifsc.edu.br
remanescentes.sj.ifsc.edu.br      IN      MX       0       mx
remanescentes.sj.ifsc.edu.br      IN      MX       10      mx


//
// Do any local configuration here
//

// Consider adding the 1918 zones here, if they are not used in your
// organization
// include "/etc/bind/zones.rfc1918";
zone "remanescentes.sj.ifsc.edu.br" {
  type master;
  file "/etc/bind/remanescentes.zone";
  /etc/bind/nat.local
allow-transfer {200.135.37.65; };
};
// reverso
zone "16.16.172.in-addr.arpa" {
      type master;
      file "/etc/bind/db.176";
allow-transfer { 200.135.37.65; };
};


; BIND data file for local loopback interface
;
$TTL   604800
@        IN       S0A      ns1.remanescentes.sj.ifsc.edu.br. root.remanescentes.sj.ifsc.edu.br. (
                                 1               ; Serial
                            604800               ; Refresh      
                             86400               ; Retry
                           2419200               ; Expire
                            604800 )             ; Negative Cache TTL

;
@        IN        NS       remanescentes.sj.ifsc.edu.br .
254      IN        PTR      ns1.remanecentes.sj.ifsc.edu.br .
mail     IN        A        127.16.16.253

16/06/2014

sudo apt-get autoremove
sudo apt-get clean
sudo apt-get install freeradius freeradius-mysql
nano/etc/freeradius/users
radtest abc 123 localhost 1812 testing 123 
create database radius
exit


  • Configuração da interface
sudo ifconfig eth0 200.135.37.96/26
sudo nano /etc/network/interface
sudo ifconfig eth0 up
sudo ifconfig eth0 down
sudo /etc/network/resolv.conf
ifcondig
ping 8.8.8.8
sudo route add default gw 200.135.37.126
ping www.google.com.br

- Não foi possível fazer a configuração do roteador, pois ele não fornecia o IP, e mesmo resetando as configurações de fabrica ele não aceitava o IP padrão (192.168.2.10). Mas com o cabo de rede conectado conseguia fazer o roteamento de internet.

ifconfig eth0 192.168.2.10

17/06/2014

  • Por motivo do jogo da Seleção Brasileira, não haverá aula.

18/06/2014

  • Conseguimos fazer a configuração do Edimax fixando IP (192.168.2.115), gateway (192.168.2.1), via wireless, foi acessado as configurações onde foi alterado o SSID, e o mesmo possui a função de autenticação de radius.
  • Criação de usuários do SSH
  • Instalação do TeamViewer
  • Habilitado o radius no Edimax

19/06/2014

  • Feriado de Copus Christi, não haverá aula.

20/06/2014

  • Recesso institucional, não haverá aula.

22/06/2014

  • Fizemos a reinstalação do sistema, estamos com problemas de hardware, porém pode ser corrigido com um script de inicialização no sistema.
  • Sistema instalado atualmente ubuntu server 14.04 LTS, notamos uma melhora na estabilidade e velocidade.

23/06/2014

  • Por motivo do jogo da Seleção Brasileira, não haverá aula.

24/06/2014

  • Foi iniciada a configuração do FreeRadius.
  • E iniciamos o site da nossa empresa.

25/06/2014

  • Terminada a configuração do Freeradius
  • Ajuste dos links de acesso
  • Foram feitas algumas modificações no site

26/06/2014

  • O Professor Saul passou uma introdução sobre a fibra óptica até o intervalo, e depois iniciamos o processo de fusão da fibra.
  • Emenda Mecânica

Fusao1.jpg


  • Fusão da Fibra Óptica

Fusao2.jpg


27/06/2014

  • Foi feita a algumas instalação de programas.
sudo apt-get install realvnc
sudo apt-get install slapd ldap-utils
sudo apt-get install liblzo2-dev
sudo apt-get install liblzo2-dev
sudo apt-get install x11vnc
  • Instalação e configuração do PostFix
sudo apt-get upgrade
sudo apt-get update
sudo apt-get install libsas12
exit
nano /etc/postfix/main.cf
sudo nano /etc/postfix/main.cf
service postfix start
sudo service postfix start
udo apt-get install mailx
exit
  • Configuração do DNS e BIND
cat /etc/bind/named.conf.local
cat /etc/bind/remanescentes.zone
cat /etc/bind/db.176
sudo nano /etc/bind/named.conf.local
sudo nano /etc/bind/remanescentes.zone
sudo nano /etc/bind/named.conf.local
sudo nano /etc/bind/remanescentes.zone
cp /etc/bind/db.176 /etc/bind/db.200
sudo cp /etc/bind/db.176 /etc/bind/db.200
sudo nano /etc/bind/db.200
sudo nano /etc/bind/remanescentes.zone
sudo nano /etc/postfix/main.cf
sudo apt-get install mailx
sudo apt-get update && sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-cache search mailx
sudo apt-get install mailutils

30/06/2014

  • Realizado algumas alteração no site.
  • Configuração do Switch Catalyst 2960-S series SI, não conseguimos realizar a configuração, pois o Switch não configurava pela ethernet e não fixava o ip.

Switch14.jpg

01/07/2014

  • Tivemos um problema no site, não era possível acessa-lo em outra máquina. O problema já foi solucionado.
  • Devido ao problema ocorrido na aula passada, onde o Switch não dava para ser configurado, pois não fixava ip e nem via internet. Reiniciamos novamente para fazer a configuração.

02/07/2014

  • Primeiras 2 aulas: Avaliação A2 PRC;
  • Últimas 2 aulas: Avaliação A1 IER;

03/07/2014

  • Foi feito a parte de fusão da fibra óptica do projeto integrador.

04/07/2014

  • Por motivo do jogo da Seleção Brasileira, não haverá aula.

05/07/2014

  • Prazo final para entrega do Trabalho de CAD para o Profº Saul.
  • Apenas teste de conexão e atualização de rotina.

06/07/2014

  • Corrigido problemas com nosso DNS, agora podemos acessar o site através remanescentes.sj.ifsc.edu.br, acesso pela rede do IFSC.
  • Revisão das configurações do LDAP, instalação do phpldapadmin, acesso as configurações via browser interna/externamente.
  • Freeradius configurado e funcionando por testes internos, devemos configurar o AP novamente, para testar a autenticação e configurar o IP.
  • Conseguimos descobrir o erro na configuração do Switch, este será nossa prioridade no dia 07/07/14.

07/07/2014

Configuração do Switch via terminal.

enable
password:

Configure terminal
interface vlan 1
ip address 10.10.10.20 255.255.0.0
no shutdown
exit

ip default-gateway 10.10.10.2
vlan 20
name remanescentes
exit

interface fastEthernet 0/10

08/07/2014

  • Por motivo do jogo da Seleção Brasileira, não haverá aula.

09/07/2014

  • Configurando Switch Cisco Catalyst 2960s

10/07/2014

  • Configurando o Switch Catalyst 2960-S Séries SI
  • Segurar o botão por três segundos até piscar os Led's, com o mesmo botão por sete segundos, fazendo o que o Switch seja resetado.
  • Utilizar o cabo adaptador RJ45 no switch e serial no computador, configuração efetuada junto ao Prof Casagrande.
  • Membros de nossa equipe estava junto ao Prof Saul, para reparar fibra defeituosa, link fibra funcionando.
  • Abrir o terminal
#sudo minicom
  • Criando a Vlan
Switch(config)#vlan 10
Switch(config-vlan)#name nat
Switch(config-vlan)#end
Switch#conf t

Switch(config)#vlan 20
Switch(config-vlan)#name remanescentes
Switch(config-vlan)#end
Switch#conf t

Switch(config)#vlan 30
Switch(config-vlan)#name ccorp
Switch(config-vlan)#end
Switch#conf t

Switch(config)#vlan 40
Switch(config-vlan)#name teleplus
Switch(config-vlan)#end
Switch#conf t

direcionando as portas de 2 a 6 para vlan 10
direcionando as portas de 7 a 12 para vla 20
direcionando as portas de 13 a 18 para vlan 30
direcionando as portas de 19 a 23 para vlan 40

Switch(config)#init range gigabitEthernet 0/2 - 6
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#end

Switch(config)#init range gigabitEthernet 0/7 -12
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config-if-range)#end


Switch(config)#init range gigabitEthernet 0/13 -18
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 30
Switch(config-if-range)#end


Switch(config)#init range gigabitEthernet 0/19 -23
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 40
Switch#(config-if-range)#end

Switch#show vlan brief
* Spaning-tree habilitados em todas as vlans
Switch(config)#spaning-tree vlan 10 root primary
Switch(config)#spaning-tree vlan 20 root primary
Switch(config)#spaning-tree vlan 30 root primary
Switch(config)#spaning-tree vlan 40 root primary

* Habilitando trunk nas portas 1 e 24 de cada switch
Switch>enable
Switch#conf t
Switch(config)#interface gigafastEthernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)end

Switch#conf t
Switch(config)#interface gigafastEthernet 0/24
Switch(config-if)#switchport mode trunk
Switch(config-if)end

* Configurando endereço de gerenciamento nos Switchs
* Switch remanescentes (vlan 20)
Switch>enable
Switch#conf t
Switch(config)#interface vlan 20
Switch(config-if)#ip address 10.0.0.40 255.255.255.0
Switch(config-if)#no shutdown

* Switch ccorp (vlan 30)
Switch>enable
Switch#conf t
Switch(config)#interface vlan 20
Switch(config-if)#ip address 10.0.0.41 255.255.255.0
Switch(config-if)#no shutdown

* Switch teleplus (vlan 40)
Switch>enable
Switch#conf t
Switch(config)#interface vlan 40
Switch(config-if)#ip address 10.0.0.42 255.255.255.0
Switch(config-if)#no shutdown
  • Testes nos Switchs, trunk e vlan funcionando corretamente, spaning-tree ativado e funcionando.

Referência: http://www.dltec.com.br/blog/cisco/como-criar-vlan-e-alocar-portas-em-switches-cisco-ccna/

Referência: http://technator.blogspot.com.br/2011/01/cisco-configurando-spanning-tree_19.html

Referência: http://www.ti-redes.com/switching/configura%C3%A7%C3%B5es%20basicas/comandos-basicos-de-switches-cisco/

  • Foi criado banco de dados porém não funciona, pois não está sendo possível fazer o link entre o MSQL com o banco de dados.
  • Foi configurado os três switchs algumas vezes para conseguir fazer todas as configuração sem erros.
  • Foi nós passado um switch no começo do PI e esse foi configurado á muito custo e quando configurado foi tracado por um equipamento que não estava funcionando.

11/07/2014

Foi feito a reconfiguração dos Switches.