Projeto Integrador - 2014.1 - NAT

De MediaWiki do Campus São José
Ir para: navegação, pesquisa
NAT.jpg


Projeto Integrador - NAT - Network Adress Transmision

10/06: Iniciando o Projeto Integrador (CAB (Terça-Feira)

  • Início do Projeto.
  • Primeiro contato com os integrantes do Projeto Integrador.
  • Os integrantes do grupo são: Jeferson, Gerson, Vinícius, Hyowata.
  • Primeiramente instalamos a fibra óptica FURUKAWA INDOOR/OUTDOOR TYPE OFNR

Fibra.jpg

  • Verificamos a integridade física da máquina fornecida pelo IFSC

11/06: Segundo dia do PI (IER (Quarta-Feira)

  • Começamos a instalação do Ubuntu Server 12.04 LTS

Ubuntu.jpg

Testset.jpg Testse2.jpg

Descrição do Servidor

  • Configuração do Sistema Operacional:
cat /etc/issue
Ubuntu 12.04.4 LTS \n \l
  • Para verificar a configuração do Hardware:
  • Memória (Total 2Gb):
free 
             total       used       free     shared    buffers     cached
Mem:       2055312     251216    1804096          0      11556     200784
-/+ buffers/cache:      38876    2016436
Swap:      3048572          0    3048572
  • Processador:
cat /proc/cpuinfo
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 15
model		: 6
model name	: Intel(R) Celeron(R) D CPU 3.06GHz
stepping	: 5
microcode	: 0x9
cpu MHz		: 3059.161
cache size	: 512 KB
  • HD (total: 320Gb):
df -h
Sist. Arq.      Tam. Usado Disp. Uso% Montado em
/dev/sda5       138G  2,7G  129G   3% /
udev            995M  4,0K  995M   1% /dev
tmpfs           402M  356K  402M   1% /run
none            5,0M     0  5,0M   0% /run/lock
none           1004M     0 1004M   0% /run/shm
/dev/sda1       453M   30M  396M   8% /boot
/dev/sda6       155G  267M  147G   1% /var

Configurando do Servidor

  • Desabilitando Ctrl + Alt + Del.
  • Foi editado o seguinte arquivo:
vim /etc/init/control-alt-delete.conf
  • Foi comentado a linha abaixo:
exec shutdown -r now "Control-Alt-Delete pressed"
  • Atualizando o Sistema.
sudo apt-get update
sudo apt-get upgrade
  • Instalando SSH.
sudo apt-get install ssh
  • Configurando Usuarios.
useradd gerson
useradd hyowata
useradd jeferson
useradd vinicius
  • Desabilitando ssh do ROOT editando o arquivo /etc/ssh/sshd_config.
## Na linha PermitRootLogin yes para ##
PermitRootLogin no

13/06: Terceiro dia do PI (GER (Sexta-Feira)

Configurado Bind9 como servidor DNS

  • Instalação do bind9:
sudo apt-get install bind9
  • Editado o arquivo de configuração /etc/bind/named.conf.local
zone "nat.sj.ifsc.edu.br" {
 type master;
 file "/etc/bind/nat.zone";
 // abaixo fica autorizado que IFSC copie o conteúdo da zona !!! secundario
allow-transfer { 200.135.37.65; };
};
// reverso
zone "99.37.135.200.in-addr.arpa" {
       type master;
       file "/etc/bind/db.172";
allow-transfer { 200.135.37.65; };
};
  • Editado o arquivo de configuração de zona /etc/bind/nat.zone
$TTL    604800
@       IN      SOA     nat.sj.ifsc.edu.br. root.nat.sj.ifsc.edu.br. (
                              2         ; Serial
                         604800         ; Refresh
                          86400         ; Retry
                        2419200         ; Expire
                         604800 )       ; Negative Cache TTL
;
@       IN      A       200.135.37.99
@       IN      NS      ns1.nat.sj.ifsc.edu.br.
@       IN      A       127.0.0.1
@       IN      AAAA    ::1
ns1     IN      A       200.135.37.99
www     IN      CNAME   nat.sj.ifsc.edu.br.
nat.sj.ifsc.edu.br.     IN      MX      0       mx
nat.sj.ifsc.edu.br.     IN      MX      10      mx
  • Editado o arquivo de configuração de db /etc/bind/db.172
$TTL    604800
@       IN      SOA     ns1.nat.sj.ifsc.edu.br. root.nat.sj.ifsc.edu.br. (
                             1         ; Serial
                        604800         ; Refresh
                         86400         ; Retry
                       2419200         ; Expire
                        604800 )       ; Negative Cache TTL
;
@       IN      NS      nat.sj.ifsc.edu.br.
99     IN      PTR     ns1.nat.sj.ifsc.edu.br.
mail     IN     A       200.135.37.99

Configurado isc-dhcp-server como servidor DHCP

  • Instalação do isc-dhcp-server:
sudo apt-get install isc-dhcp-server
  • Configurando personalizado o arquivo /etc/dhcp/dhcpd.conf
default-lease-time 600;
max-lease-time 7200;
option subnet-mask 255.255.255.0;
option broadcast-address 172.16.1.255;
option routers 172.16.1.254;
option domain-name-servers 200.135.37.99, 200.135.37.65;
option domain-name "nat.sj.ifsc.edu.br";

subnet 172.16.1.0 netmask 255.255.255.0 {
range 172.16.1.50 172.16.1.200;
}
  • Configurando qual interface vai entregar IP editando o arquivo /etc/default/isc-dhcp-server
INTERFACES="eth1"

16/06: Quarto dia do PI (PRC (Segunda-Feira)

Configurando IP Externo

Conf IP.jpg

  • Fizemos a configuração e fizemos a fixação da maquina no armário.

Maquina1.jpg

18/06: Iniciando a esquematização do Site (IER (quinta-Feira)

  • Definimos como será feita a pagina principal do nosso site.
  • Definido IPs internos, externos entro os roteadores segue abaixo:

IPs.jpg

  • O servidor foi configurado para acesso remoto.

Remot.jpg

apt-get install apache2
ping google.com
apt-get install traceroute
apt-get install --no-install-recommends xubuntu-desktop
sudo apt-get install xfce4
  • Configuramos AccessPoint D-Link DI-524, para mascara de rede 172.16.1.0/24

Dlink.jpg

24/06: Projeto integrador (GAR (terça-Feira)

  • Foi corrigido os IP'S de 178 para 172.
  • Foi corrigido os IP'S do DHCP e respectivas interfaces.

Instalado o servidor de email POSTFIX

apt-get install postfix
apt-get install mailutils
vi /etc/postfix/main.cf

*Foi alterado as configurações para o host da NAT

myhostname = nat.sj.ifsc.edu.br
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydestination = nat, localhost.localdomain, , localhost
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
mydomain = nat.sj.ifsc.edu.br
mynetwork_style = subnet
service postfix start
root@nat:~# mail hyowatha@gmail.com
Cc: 
Subject: testes
tetstets

Instalado e configurado FreeRaius:

apt-get install  freeradius freeradius-ldap freeradius-common
apt-get install openldap-server
aptitude install apache2 libapache2-mod-php5 php5 php5-cgi php5-ldap
aptitude install phpldapadmin 
dpkg-reconfigure slapd
apt-get install ldap-utils
ufw allow 80
ufw allow 389
  • Configurado os arquivos com os respectivos conteúdos LDAP:
vim /etc/ldap/ldap.conf
BASE	dc=nat,dc=sj,dc=ifsc,dc=edu,dc=br
URI	ldap://200.135.37.99
vim /etc/phpldapadmin/config.php
$servers->setValue('login','bind_id','cn=admin,dc=sj,dc=ifsc,dc=edu,dc=br');
$servers->setValue('server','base',array('dc=sj,dc=ifsc,dc=edu,dc=br'));
$servers->setValue('login','bind_id','cn=admin,dc=sj,dc=ifsc,dc=edu,dc=br');
vim /etc/freeradius/modules/ldap
#modificar as seguintes linhas
server = "nat.sj.ifsc.edu.br"
basedn = "dc=nat,dc=sj,dc=ifsc,dc=edu,dc=br"
filter = "(uid=%u)"
access_attr = "uid"
edir_account_policy_check = yes 
dictionary_mapping = ${confdir}/ldap.attrmap
vim /etc/freeradius/sites-enabled/default
authorize {
    ldap
    expiration
    logintime
}

authenticate {
    Auth-Type LDAP {
        ldap
    }
}

preacct {
    preprocess
    acct_unique
    suffix
    files
}

accounting {
    detail
    unix
    radutmp
    attr_filter.accounting_response
}

session {
    radutmp
}

post-auth {
    Post-Auth-Type REJECT {
        attr_filter.access_reject
    }
}
vim /etc/freeradius/clients.conf
client localhost {
        ipaddr = 127.0.0.1
        secret = testing123
        require_message_authenticator = no
}
# Exemplo de configuração para rede (caso não utilize, comente as 4 linhas abaixo)
client 172.16.1.0/24 {
        secret          = sw2011
        shortname       = switches-3com
 }
# Exemplo de configuração para host (caso não utilize, comente as 4 linhas abaixo)
client 172.16.1.4 {
        secret          = wl2011
        shortname       = ap-wireless
}
vim /etc/freeradius/radiusd.conf
prefix = /usr
exec_prefix = /usr
sysconfdir = /etc
localstatedir = /var
sbindir = /usr/sbin
logdir = /var/log/radius
raddbdir = /etc/freeradius
radacctdir = /var/log/radius/radacct
name = radiusd
confdir = ${raddbdir}
run_dir = ${localstatedir}/run/${name}
db_dir = ${raddbdir}
libdir = /usr/lib/freeradius
pidfile = ${run_dir}/${name}.pid
max_request_time = 30
cleanup_delay = 5
max_requests = 1024
listen {
        type = auth
        ipaddr = *
        port = 0
}
listen {
        ipaddr = *
        port = 0
        type = acct
}
hostname_lookups = no
allow_core_dumps = no
regular_expressions     = yes
extended_expressions    = yes
log {
        destination = files
        file = ${logdir}/radius.log
        syslog_facility = daemon
        stripped_names = no
        auth = yes
        auth_badpass = yes
        auth_goodpass = yes
}
checkrad = ${sbindir}/checkrad
security {
        max_attributes = 200
        reject_delay = 1
        status_server = yes
}
proxy_requests  = yes
$INCLUDE proxy.conf
$INCLUDE clients.conf
thread pool {
        start_servers = 5
        max_servers = 32
        min_spare_servers = 3
        max_spare_servers = 10
        max_requests_per_server = 0
}
modules {
        $INCLUDE ${confdir}/modules/
        $INCLUDE eap.conf
}
instantiate {
        exec
        expr
        expiration
        logintime
}
$INCLUDE policy.conf
$INCLUDE sites-enabled/
#testando
radtest abc 123 localhost 1812 testing123

25/06: Projeto integrador (IER (quarta-Feira)

  • Instalado e configurado X11vnc:

26/06: Projeto integrador (CAB (quinta-Feira)

Fusao1.jpg

  • Fusão da Fibra Óptica

Fusao2.jpg

27/06: Projeto integrador (GER (sexta-Feira)

Configuramos AccessPoint D-Link DI-524

    • Removido DHCP interno do AP.
    • Configurado com IP fixo da nossa interface interna.
  • Corrigido os endereços IP do DNS.
  • Realizado comando para trocar pacotes da interface WAN do servidor:
# Temporario #
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
  • Configuramos um script para iniciar com este comando:
vim /etc/init.d/nat_habilita.sh
# Com o conteudo:

#!/bin/bash
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

# Dando permissão para executar
chmod +x /etc/init.d/nat_habilita.sh
  • Realizado comando para rotear pacotes da interface WAN do servidor:
echo 1 >  /proc/sys/net/ipv4/ip_forward
  • Pesquisamos sobre como colocar FreeRadius no AccessPoint D-Link DI-524.ChilliSpot

30/06: Projeto integrador (PRC (Segunda-Feira)

  • Iniciamos a configuração do FreeRadius + Hotspot (com chillispot)

configurado como o tutorial e nada https://help.ubuntu.com/community/WifiDocs/ChillispotHotspot

01/07: Projeto integrador (GER (Terça-Feira)

  • Configuramos do FreeRadius + Hotspot (com chillicoova)

configurado como o tutorial e nada http://www.vivaolinux.com.br/topico/Redes/Coovachilli-Captive-Portal


09/07: Projeto integrador (IER (Quarta-Feira)

  • Configuramos as VLANS no switch cisco Catalyst 2960-S
sudo minicom
Switch>enable
Switch(config)#vlan 10
Switch(config-vlan)#name nat
Switch(config-vlan)#end
Switch#conf t
 
Switch(config)#vlan 20
Switch(config-vlan)#name remanescentes
Switch(config-vlan)#end
Switch#conf t
 
Switch(config)#vlan 30
Switch(config-vlan)#name ccorp
Switch(config-vlan)#end
Switch#conf t
 
Switch(config)#vlan 40
Switch(config-vlan)#name teleplus
Switch(config-vlan)#end
Switch#conf t
 
direcionando as portas de 2 a 6 para vlan 10
direcionando as portas de 7 a 12 para vla 20
direcionando as portas de 13 a 18 para vlan 30
direcionando as portas de 19 a 23 para vlan 40
 
Switch(config)#init range gigabitEthernet 0/2 - 6
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#end
 
Switch(config)#init range gigabitEthernet 0/7 -12
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config-if-range)#end
 
 
Switch(config)#init range gigabitEthernet 0/13 -18
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 30
Switch(config-if-range)#end
 
 
Switch(config)#init range gigabitEthernet 0/19 -23
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 40
Switch#(config-if-range)#end
 
Switch#show vlan brief

* Spaning-tree habilitados em todas as vlans
Switch(config)#spaning-tree vlan 10 root primary
Switch(config)#spaning-tree vlan 20 root primary
Switch(config)#spaning-tree vlan 30 root primary
Switch(config)#spaning-tree vlan 40 root primary
 
* Habilitando trunk nas portas 1 e 24 de cada switch
Switch>enable
Switch#conf t
Switch(config)#interface gigafastEthernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)end
 
Switch#conf t
Switch(config)#interface gigafastEthernet 0/24
Switch(config-if)#switchport mode trunk
Switch(config-if)end
 
* Configurando endereço de gerenciamento nos Switchs

* Switch remanescentes (vlan 10)
Switch>enable
Switch#conf t
Switch(config)#interface vlan 10
Switch(config-if)#ip address 10.0.0.40 255.255.255.0
Switch(config-if)#no shutdown
 
* Switch remanescentes (vlan 20)
Switch>enable
Switch#conf t
Switch(config)#interface vlan 20
Switch(config-if)#ip address 10.0.0.41 255.255.255.0
Switch(config-if)#no shutdown
 
* Switch ccorp (vlan 30)
Switch>enable
Switch#conf t
Switch(config)#interface vlan 30
Switch(config-if)#ip address 10.0.0.42 255.255.255.0
Switch(config-if)#no shutdown
 
* Switch teleplus (vlan 40)
Switch>enable
Switch#conf t
Switch(config)#interface vlan 40
Switch(config-if)#ip address 10.0.0.42 255.255.255.0
Switch(config-if)#no shutdown

Vl1.jpg

10/07: Projeto integrador (CAB (Quinta-Feira)

  • Instalando coova
apt-get install coova
  • Configurando coova edite o arquivo /etc/chilli/config
HS_LANIF=eth1		   # Subscriber Interface for client devices
HS_NETWORK=172.16.1.0	   # HotSpot Network (must include HS_UAMLISTEN)
HS_NETMASK=255.255.255.0   # HotSpot Network Netmask
HS_UAMLISTEN=172.16.1.254	   # HotSpot IP Address (on subscriber network)
HS_UAMPORT=3990            # HotSpot UAM Port (on subscriber network)
HS_UAMUIPORT=4990          # HotSpot UAM "UI" Port (on subscriber network, for embedded portal)
# OpenDNS Servers
HS_DNS1=200.135.37.99
HS_DNS2=200.135.37.65
HS_NASID=localhost
HS_RADIUS=localhost
HS_RADIUS2=localhost
#HS_UAMALLOW=172.16.1.0/24
HS_RADSECRET=testing123    # Set to be your RADIUS shared secret
HS_UAMSECRET=nat     # Set to be your UAM secret
HS_UAMALIASNAME=chilli
#   Optional initial redirect and RADIUS settings
HS_SSID="NAT" # To send to the captive portal
# HS_NASMAC=<mac address>  # To explicitly set Called-Station-Id
HS_NASIP=127.0.0.1    # To explicitly set NAS-IP-Address
HS_UAMSERVER=$HS_UAMLISTEN
HS_UAMFORMAT=http://\$HS_UAMLISTEN:\$HS_UAMUIPORT/www/login.chi
HS_UAMHOMEPAGE=http://200.135.37.99/indexcadastro.php
HS_MACAUTH=on
HS_RADCONF_SERVER=https://172.16.1.254		 # RADIUS Server
HS_RADCONF_SECRET=testing123		 # RADIUS Shared Secret 
HS_RADCONF_AUTHPORT=1812			 # Auth port
HS_RADCONF_USER=abc			 # Username
HS_RADCONF_PWD=123
HS_TCP_PORTS="80 443 23 25 587 8000"
HS_MODE=hotspot
HS_TYPE=chillispot
HS_WWWDIR=/etc/chilli/www
HS_WWWBIN=/etc/chilli/wwwsh
HS_PROVIDER=Coova
HS_PROVIDER_LINK=http://nat.sj.ifsc.edu.br
HS_LOC_NAME="NAT HotSpot"	   # WISPr Location Name and used in portal

Coova.jpg Coova2.jpg

Referencias

VER

http://www.radiusdesk.com/getting_started/install_ubuntu_coovachilli

http://www.vivaolinux.com.br/dica/Criando-seu-proprio-Captive-Portal

http://coova.org/node/3960

http://www.vivaolinux.com.br/artigo/Hotspot-Atualizacao-CoovaChilli/?pagina=2

ivaolinux.com.br/artigo/Hotspot-rapido-com-Coovachilli?pagina=2

VLAN

http://www.dltec.com.br/blog/cisco/como-criar-vlan-e-alocar-portas-em-switches-cisco-ccna/


http://aryo.info/labs/captive-portal-using-php-and-iptables.html

http://www.vivaolinux.com.br/artigo/Hotspot-Atualizacao-CoovaChilli/?pagina=2

http://www.vivaolinux.com.br/artigo/Hotspot-rapido-com-Coovachilli

http://www.chillispot.org/chilliforum/forum12-chillispot-configuration.html

http://www.chillispot.org/chilliforum/forum16-radius-configuration.html

http://vuksan.com/linux/dot1x/802-1x-LDAP.html

https://help.ubuntu.com/community/WifiDocs/ChillispotHotspot

http://www.stato.blog.br/wordpress/?p=738

http://www.unixmen.com/openldap-installation-configuration-ubuntu-12-1013-0413-10-debian-67-2/

http://www.vivaolinux.com.br/artigo/Entendendo-o-LDAP/?pagina=4

http://www.vivaolinux.com.br/artigo/Tutorial-completo-de-implementacao-de-LDAP-+-Samba-+-Squid/

http://www.sourcebrasil.org/tutoriais/visualizar/openfire-no-ubuntu-server-usando-banco-de-dados-do-ad.html

http://www.unitednerds.org/thefallen/docs/?area=LDAP&tuto=LDAP-NSS_Ldap

http://www.vivaolinux.com.br/artigo/Configurando-um-servidor-Freeradius-+-openLDAP

http://www.tldp.org/HOWTO/archived/LDAP-Implementation-HOWTO/radius.html

http://www.vivaolinux.com.br/artigo/Configuracao-simples-Samba-+-LDAP?pagina=3

http://www.tldp.org/HOWTO/archived/LDAP-Implementation-HOWTO/radius.html

http://repositorio.roca.utfpr.edu.br/jspui/bitstream/1/416/1/CT_GESER_1_2011_14.pdf

http://softwarelivre.org/gomex/blog/openldap-samba-como-alternativa-livre-ao-active-directory

http://www.vivaolinux.com.br/artigo/Configurando-um-servidor-Freeradius-+-openLDAP

http://stackoverflow.com/questions/23869249/freeradius-ldap-mikrotik-client-clear-text-password-not-available

http://www.vivaolinux.com.br/topico/Adminitradores-Mikrotik/Servico-ldap/